Zen Cart 雑談処「禅亭」 :: php4.4.6 は危険かも

投稿者: hide-10
件名: php4.4.6 は危険かも
日時: 2007年04月29日(Sun) 12:16 (GMT 9)
トピック 返信: 1

ご無沙汰しております。

お役に立つかどうかわかりませんが、体験談を・・。

アメリカのレンタル・サーバーを使い、ZenCart1.3.6を問題なく運用していたところ、突然、自動送信される日本語メールの本文だけが、「文字化け」するようになってしまいました。

(ちなみにZenCartだけでなく、他に使用しているWebアプリも同様です。)

サーバー会社に問い合せても、最初は適当にあしらわれていたのですが、時間が経つにつれ、対応が変わってきました。というのも、同様のクレームがどうやら殺到しているらしいのです。

で、色々調べているうちにわかったのが、サーバー会社がなんのアナウンスもなしに、php4.4.4から4.4.6にアップしていたのです。

サーバー会社に問合せをしてから約1ヶ月間、じっと対応を見守ったのですが未だ解決せずです(とほほ Confused )とはいえ、php.iniを書き換えたりなど、色々実験は続けています。

解決方法をネットで検索しているのですが、なかなか見つかりません。

困りましたー。 Crying or Very sad

_________________
○使用バージョン:zen-cart-v1.2.0-l10n-jp-1-2。最近、zen-cart-v1.2.0-l10n-jp-1-3を別途インストールをして、構築&テスト中

○サーバー(アメリカのレンタルサーバー) 

   Linux, Apache 1.3.33 (Unix), PHP 4.3.10, MySLQ 4.0.23-standard, …